Errr that is the one thing I really hate when I use to be a technician... It's drivers, they can be such a pain in the ass. So ya you can try the kernel, also like I said Distro and version type can make a diff but I know you want to stick with 6.1, yet I've seen and heard of different distros being more compatible with some things then others. I would contact Red Hat or the card manufactors and see what they say. Don't use Tulip, errr ya sry bro, I'll see what I can find tonight.
_________________________
-hKzKnight
"The ghost... Was never there and you'll never see me"