i tried doing what you reccomended and this r the results:

PING http://www.google.akadns.net [216.239.63.104] 56[84] bytes of data.
64 bytes from 216.239.63.104: icmp_seq=1 ttl=234 time=234 ms
64 bytes from 216.239.63.104: icmp_seq=2 ttl=234 time=230 ms
64 bytes from 216.239.63.104: icmp_seq=3 ttl=234 time=246 ms
64 bytes from 216.239.63.104: icmp_seq=4 ttl=234 time=230 ms
64 bytes from 216.239.63.104: icmp_seq=5 ttl=234 time=229 ms

--- http://www.google.akadns.net ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 22322ms
rtt min/avg/max/mdev = 229.261/234.434/246.964/6.539 ms

i also tried using ping in windows, and the results were:
pinging http://www.google.akadns.net[64.233.171.99] with 32 bytes of data:
response from 64.233.171.99; bytes=32 time=181ms ttl=239
response from 64.233.171.99; bytes=32 time=243ms ttl=239
response from 64.233.171.99; bytes=32 time=266ms ttl=239
response from 64.233.171.99; bytes=32 time=182ms ttl=239
packets: sent=4 received=4 lost=0
<0% packet loss>
maximum time:181ms
minimum time:266ms
average time:218ms

the whole process took 4 seconds in windows and at least 20 in linux
i also tried tracerouting google
traceroute: warning: http://www.google.com has multiple adresses; using 66.102.7.104
traceroute to http://www.google.akadns.com[66.102.7.104], 30 hops max,38 byte packets
1 192.168.8.1 0.695 ms 0.667ms 0.681ms
afater that all the following lines looked like this
2 ***
3 ***
4 ***
till the numbers reached 30

then i tracerouted http://www.yahoo.com
the results were:
traceroute: warning: http://www.yahoo.com has multiple adresses; using 66.94.230.36
traceroute to http://www.yahoo.akadns.com[66.94.230.36], 30 hops max,38 byte packets
1 192.168.8.1 0.690 ms 0.667ms 0.674ms
and then the same thing as when tracerouting google happened
i had to change some of the parenthesis for brackets because the forum showed some error message

i didnt try using firefox but my distro came with mozilla and it had the problem too.
btw, i forgot to mention that i hav a router, in case it has anything to do.
finally, about configuring DHCP, does anyone know of a webpage with info about it?