it could be that they blocked the port that kazaa uses as its default (which is like 3977 or something), so try this. options menu->options. firewall tab. change the port to 80 and/or check the box that says use port 80 as alternate if you have it. they can't have port 80 blocked i wouldn't think. just a guess.