Linux users still at risk from KDE flaw

Posted by: Digital Geek

Linux users still at risk from KDE flaw - 05/19/05 05:27 PM

Linux users who patched their systems for a serious security vulnerability in KDE last month will have to patch once again, due to errors in the original patch, according to the KDE project.

The vulnerability affects kdelibs, specifically an error in the kimgio component when processing PCX image files. Kimgio is used in KHTML-based Web browsers as well as KDE imaging applications such as kpresenter and ksnapshot, meaning that if an image crafted to exploit the flaw were viewed in any of these applications, they could allow an attacker to execute malicious code and take over a system. The flaw affects KDE versions 3.2 to 3.4, according to KDE.

The patches issued last month fixed most of the problems, but still allowed local users to exploit the bug by serving files from the /tmp directory, KDE said in an advisory. They also introduced a new bug, breaking kimgio's compatibility with .rgb images.

The problems will mean a fresh round of patching for Unix-derived systems using KDE, one of the two most popular desktop environments for Unix and Linux. KDE released a new patch fixing the problems with the original patch, and operating system vendors such as Red Hat and Suse have followed suit this week.

Software vendors are under pressure to deliver timely patches, but faulty updates are not unknown as a result, say security experts. Last week, for instance, Microsoft re-released a critical security update - - after it caused networking problems for many users.

Such problems can mean a major headache for system administrators, but they seem to be on the wane, according to Thomas Kristensen, CTO of Danish security firm Secunia. "Generally speaking I'd say that most vendors have improved significantly over the last two years when it comes to quality testing of their security fixes," he said.

SOURCE