missing libs?

Posted by: Gollum

missing libs? - 04/17/04 11:17 PM

ok...so recently, i decided to run dropline-installer to upgrade my installation. this is the only thing i can think of that might have caused this. but, what happened. is that now i'm missing libraries. libiconv.so.2 etc... or, it's saying it can't find them. even though my ld.so.conf file lists all my lib directories, and i ran ldconfig. as well as trying to export LD_LIBRARY_PATH to include my lib directories. apache is telling me it can't find libdb-4.1.so. even though it's in /usr/lib. nto only that, but i created a symbolic link to /usr/local/lib just in case. gaim gives me the error of not finding the libiconv librarary. which hasn't happened b4. and also, XMMS is now missing! wtf is going on? i've ran dropline-gnome tons of times b4 without a problem. why would all this shit happen? but mostly why can't apache find the library file? i suppose all i can do is just reinstall this stuff. but i was curious if anyone else ever had this problem, so perhaps i might be able to avoid it in the future.

also:
found this:
/var/log/removed_packages/libiconv-1.9.2-i686-1dl
/var/log/removed_packages/libiconv-1.9.1-i686-1dl-upgraded-2004-03-09,23:32:42
//