UGN Security

usb problem

Posted By: pyromaniac

usb problem - 01/31/04 02:40 AM

i don't know much about computer hardware so bare with me, recently i received a printer from a friend, and when i hooked it up and it worked just fine and printed well, now when i try to print it says that "There is an error writing to USBPRN1 for the printer (Canon S330):" and it says that it may be in use by something else, and to quite other programs, as far as i know i don't have any other programs that use a usb port.
When i go into system properties it says, under the device status, that it is working properly. Any ideas are greatly appreciated.
Posted By: Shinobi

Re: usb problem - 01/31/04 03:42 AM

You probably want to start by going into device manager (If you are using windows) and look at Universal serial bus controllers to make sure nothing in there has a ? mark or an ! mark next to it, You also want to look at your printer in there and make sure there is no ? or ! next to it either. If everthing there looks fine. I'd suggest going into the properties of your printer indevice manager clicking on the driver tab and then clicking update driver, and reinstall the driver. Also you may want to make sure your printer queue is cleared out that may be clogged with documents that failed to print. I'm just throwing out ideas here but if you can tell me how those go, then we will probably be able to give you some better ideas.
Posted By: pyromaniac

Re: usb problem - 01/31/04 04:44 AM

well, so far, i checked the device manager and i didn't see a ? or a !, i didn't see the printer in the device manager, so i went to the printers folder and went to the properties of the printer and in details it has "print to the following port" and under it it has USBPRN01 (device not connected) i checked the usb cable and i it works on another computer. so it's not that. and i tried to update the drivers but it said that i have the best driver for windows. thank you for your help so far.
Posted By: Shinobi

Re: usb problem - 01/31/04 11:33 AM

Can you change the port that it prints to?? Or even try switching to a differnt physical USB port on that computer and see if it works
Posted By: sinetific

Re: usb problem - 02/01/04 02:17 AM

Don't try to update the driver. Remove it then reinstall it. Physically turn your printer off unplug it for awhile and plug it back in. I used to get these type's of problems with an old HP printer I had. Only print one document at a time.
Never cancel print jobs.
If you do cancel a print job make sure it's is completely removed from the print que and printer memory before you add a new one.
Sometimes the printer's memory becomes clogged and corrupted. It will get overflows then the next time you go to use it and send the signal to see if it's ready it will be unresponsive and therefore you get the 'inuse' or 'not connected' message. You need flush out it's memory. Unplugging it for a period of time might work.

*I have no idea if this is what is wrong with your printer, I'm just saying it could be. I know nothing about printers this is just a semi-educated conclusion drawn from half-assed research.
Posted By: pyromaniac

Re: usb problem - 02/01/04 11:15 PM

well, i have tried that, i guess that it might be broken, i was talking to someone and they said that i had fried it. i don't really need to use the printer, i can just send the stuff to the other computers, they have printers. untill i find a way to fix it.
Posted By: Shinobi

Re: usb problem - 02/02/04 11:02 AM

Didn't you say that another computer was able to print with that printer? I would suggest switching the USB ports, and if it and your computer have serial capabilitys then you should try that. Also, it may be a little far fetched but its possible, if you have other USB devices plugged in. They can draw too much power from the powersupply causing the other usb devices not to be able to draw the correct amount of power (Usually due to a old or powersupply going bad) I would also try unplugging all usb devices except printer.
Posted By: weeve

Re: usb problem - 02/08/04 12:48 PM

In short, uninstall the software that came with it, remove the driver from hardware profile. In the device manager, unplug the device, shutdown, warm boot, then once windows loads plug the sucker in. then there ya go, should work. Doesn't matter what caused it, it could be a dll overwrite you did on installng something, and you didn't pay attension, you could spend a while messing around all for something like that:/ so just do that, it should be all good, if not, contact me.
© 2018 UGN Security Forum