UGN Security

Can't unarchive Ettercap!

Posted By: Flowbe1

Can't unarchive Ettercap! - 05/08/04 11:54 PM

Alright I downloaded Ettercap from but I can't open it! After trying to figure it out I find that it's a .tar file. Now I've tried downloading the .tar archiver but that turns out to be freeware, so when I install it-because it's freeware, I assume-all i can find is a folder full of header files, source files and other [censored] but no executable program. Now I assume I'm supposed to compile all of that [censored] and create or should I say "put it together" myself but I'm no programmer; all I wan't to do is Install Ettercap! GODDAMNIT! lol


Posted By: Flowbe1

Re: Can't unarchive Ettercap! - 05/09/04 12:00 AM

Now i'm not a lazy [censored], I'm sure after a few days or weeks I could probably or maybe not put the archiver together....but my time...wait a minute I have none(school, kid, etc.) I just want a lil help or some steering in the right direction if my theory is off.
Posted By: Infinite

Re: Can't unarchive Ettercap! - 05/09/04 12:14 AM

tar is a *nix utility.

I'm willing to bet you are sitting there in windows with WinZip trying to untar this archive. That won't work in a million years.

For arguements sake, WinAce will extract the files for you in windows, but even still they will be useless to you. 1. cause you won't be able to compile em and 2. cause even if you had a compiler those files are written for *nix and won't compile properly anyways.

What you need to do is find a win32 binary for ettercap.


Ok, so I decided to find one for you. Problem is that they don't officially exist.
from ettercap README.BINARIES:
Ettercap is distributed officially ONLY in source code. Binary packages in ANY
form are NOT officially supported. Although it is not prohibited to distribute
binary packages, the authors will not respond on bugs found in them. If you
use one of these packages downloaded from Internet, redirect your bug report
to /dev/null. The authors will reply to bug reports and will be happy to find
a solution only for hand compiled executables. Every Linux distribution, but
even *BSD or Windows is different from another. What is compiled on my machine
may not work on yours because of a different version of a system library. To
avoid this type of missing dependencies, we will not distribute any binary for
any operating system. Most of the popular distributions (Debian, RedHat,
FreeBSD, OpenBSD, ecc) provide the binary packages for ettercap. Use these
packages, since they are build to work on your distribution and should have
the dependencies resolved correctly. Refer to the binary packager of your
distribution for problems regarding these packages.
So it looks like you either find a compiler for windows and compile it yourself, or install some flavor of *nix on something and do it there.

Posted By: Flowbe1

Re: Can't unarchive Ettercap! - 05/09/04 12:56 AM

Well I have a file on my desktop with no recognizable icon and it reads "Ettercap" under it; and I'm not trying to unzip it with any zip tool cause Its obviously not a zip file. Now that "tar is a *nix utility" explains a little. The full name of the file is ettercap-NG-0.7.0_pre1.tar and the properties states "Type of file: GZ file." So I then download Tar and now I know why it obviously didn't work all I got we're source files. This is what is listed on the site I got it from(Ettercap):

"Short Description: Ettercap is a suite for man in the middle attacks on LAN. It features sniffing of live connections, content filtering on the fly and many other interesting tricks.
It supports active and passive dissection of many protocols (even ciphered ones) and includes many feature for network and host analysis.

Interface: All this feature are integrated with a easy-to-use and pleasureful ncurses/gtk interfaces. (see screenshots)

Platform: Linux 2.0.x
Linux 2.2.x
Linux 2.4.x
Linux 2.6.x FreeBSD 4.x 5.x
OpenBSD 2.[789] 3.x
NetBSD 1.5 Mac OS X (darwin 1.3 1.4 5.1 6.x 7.x)
Windows 9x/NT/2000/XP
Solaris 2.x

Required Library: libpcap >= 0.8.1 and libnet >= 1.1.2
If you want SSH1 and/or HTTPS support, ettercap requires OpenSSL libraries"

Then theres a tab I could go to which offers differen't versions of Ettercap to download, mirrors, etc.

I do have Visual Studio 6.0. So all I do is copy and paste all the source, header, etc. files to a new file; compile and build and I should have my own Ettercap or something like it.....

I'm going to do what you say and see If i could fin a win32 binary for Ettercap...

Thanks for the quick response-damn!


Posted By: Infinite

Re: Can't unarchive Ettercap! - 05/09/04 02:34 AM

Hrm, you must have started replying while I was editing my post.

But if you have visual stidio then try and compile it.
Posted By: Flowbe1

Re: Can't unarchive Ettercap! - 05/09/04 04:10 AM

The only thing I can compile is the source code for the program TAR (the archiver for *nix) however, the ettercap file I can't open cause it's a .tar know what I mean. When I open the Ettercap file using Visual Studio all it shows is hex, like when I am viewing a sniffed packet.....
Posted By: Infinite

Re: Can't unarchive Ettercap! - 05/09/04 04:32 AM

Ok, you're not paying attention now...

Originally posted by Infinite:

For arguements sake, WinAce will extract the files for you in windows...

And I just checked... WinRar will do it too
Posted By: ?

Re: Can't unarchive Ettercap! - 05/09/04 04:36 AM

to untar it:

tar -zxvf filename

to install it

1. ./configure
switch to root
2. make && make install

that's how most unix programs are installed. btw, forget windows, get linux.
Posted By: Flowbe1

Re: Can't unarchive Ettercap! - 05/09/04 08:45 AM

your right bout linux...but you've got to start with baby steps. I've been in the Information biz bout 9mo. I am anxious to install and get familiar with though.

Yo infinite, thanks for you help, I'll go over your replies thoroughly and make sure I understand everything, look for a win32 binary right.....If not I'll figure it out, thanks though
Posted By: Gollum

Re: Can't unarchive Ettercap! - 05/09/04 08:57 AM

im pretty sure there is a version of ettercap for windows. i think so, because i think i have it. lemme check around, and i'll get back.

found it. this should work:
go here:
Posted By: Flowbe1

Re: Can't unarchive Ettercap! - 05/09/04 10:44 AM

Now i'm back to sqaure one....its a .tar file and I can't open it...
Posted By: ?

Re: Can't unarchive Ettercap! - 05/09/04 10:47 AM

3 seconds
Posted By: Infinite

Re: Can't unarchive Ettercap! - 05/09/04 11:17 AM

I told you twice what to use to open it. If you can't be bothered to read the answers provided then stop asking questions. You're wasting our time.
Posted By: Gollum

Re: Can't unarchive Ettercap! - 05/09/04 12:39 PM

for windows, you can use winrar. it's a free download.//
Posted By: Flowbe1

Re: Can't unarchive Ettercap! - 05/09/04 11:37 PM

Okay, I'm officially and ignorant [censored]....May God help me

Thanks for putting up with my [censored]...

Posted By: Chem

Re: Can't unarchive Ettercap! - 05/10/04 01:04 AM

WinRar > WinAce
Posted By: saliva

Re: Can't unarchive Ettercap! - 07/23/04 08:24 AM

in response to "btw, forget windows, get linux."

you should get CygWin to run ettercap on Windows
Posted By: champatram

Re: Can't unarchive Ettercap! - 08/29/04 02:46 AM

I have done the installation on RHL 9, while running ./configure it showed error "require libpcap 8.0.1" or something. I downloaded and ran lipcap. But still ettercap shows the same error message. Please help.
Posted By: §intå×

Re: Can't unarchive Ettercap! - 08/29/04 03:00 AM

/me reaches out through Flowbe1's monitor and smaks his [censored] so hard he reailises he has been given the answer to his problem.

Link for utility to un-zip g-zip or *.gz files in windows

Link for utility to un-tar or *.tar files in windows

*.tar is a way to group numerous files and make a "tar ball"

*.gz is a way to zip or compress files. What you have is a compressed tar ball.

First you need to un-tar the file, then un zip it.

Since the 2 files above are probably above your head

this will open your file...

Click the link, install the program, re-boot. now open your tar ball.

As the link above this is an easy install and will open your file.

If you do not get this, I will hunt you down and force you to lick my toe cheese. Think it's funny, my doctor puked at it's site. Reading this post was painful for me, so please please get this.
© 2018 UGN Security Forum