UGN Security

need help with linux

Posted by: javier

need help with linux - 01/04/05 03:47 PM

i installed linux a couple of days ago and i m having a problem with the web browsers.

i have broadband but when i try to access a web page the browsers do nothing for some secs(up to 30) and then downloads the page. i tried all 3 browsers of my distro(mandrake 10) and it happened in all of them.

i ran the monitor connections utility and found out that when connecting to a web page the browsers stay on 0 kbps for some secs and then transfer quickly for half a second.
anyone knows how to fix the problem or where to search for a solution?
thanxs in advance.
Posted by: Ice

Re: need help with linux - 01/04/05 09:49 PM

u must have incorrectly set up DHCP when installing the Distro.

Have u tried pinging some sites ? See if u can connect, if u cant, i prb forgot or incorrectly set up dchp.
Posted by: Gremelin

Re: need help with linux - 01/04/05 11:29 PM

Try pinging or tracerouting and respond with results.

Also, install FireFox on your distro,
Posted by: javier

Re: need help with linux - 01/05/05 07:49 AM

i tried doing what you reccomended and this r the results:

PING [] 56[84] bytes of data.
64 bytes from icmp_seq=1 ttl=234 time=234 ms
64 bytes from icmp_seq=2 ttl=234 time=230 ms
64 bytes from icmp_seq=3 ttl=234 time=246 ms
64 bytes from icmp_seq=4 ttl=234 time=230 ms
64 bytes from icmp_seq=5 ttl=234 time=229 ms

--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 22322ms
rtt min/avg/max/mdev = 229.261/234.434/246.964/6.539 ms

i also tried using ping in windows, and the results were:
pinging[] with 32 bytes of data:
response from; bytes=32 time=181ms ttl=239
response from; bytes=32 time=243ms ttl=239
response from; bytes=32 time=266ms ttl=239
response from; bytes=32 time=182ms ttl=239
packets: sent=4 received=4 lost=0
<0% packet loss>
maximum time:181ms
minimum time:266ms
average time:218ms

the whole process took 4 seconds in windows and at least 20 in linux
i also tried tracerouting google
traceroute: warning: has multiple adresses; using
traceroute to[], 30 hops max,38 byte packets
1 0.695 ms 0.667ms 0.681ms
afater that all the following lines looked like this
2 ***
3 ***
4 ***
till the numbers reached 30

then i tracerouted
the results were:
traceroute: warning: has multiple adresses; using
traceroute to[], 30 hops max,38 byte packets
1 0.690 ms 0.667ms 0.674ms
and then the same thing as when tracerouting google happened
i had to change some of the parenthesis for brackets because the forum showed some error message

i didnt try using firefox but my distro came with mozilla and it had the problem too.
btw, i forgot to mention that i hav a router, in case it has anything to do.
finally, about configuring DHCP, does anyone know of a webpage with info about it?
Posted by: Gremelin

Re: need help with linux - 01/05/05 08:01 AM

You're able to connect to the internet; thus you're able to pull a connection to your router... Do you have any other computers behind your router that you could try pinging/tracerouting to validate that either your line doens't suck or your router isn't being a pain in the ass?

also, what model router?
Posted by: sinetific

Re: need help with linux - 01/05/05 01:21 PM

If your router is configured to be a dhcp server. You would just type in 'dhcpcd' or whatever the mandrake dhcp client alias is and it automatically uses your router's configured dhcp settings. That might be your problem.

My suggestion is to nslookup, ping the domain than ping the address compare the times. If the domain takes a long time to resolve you problem is with your dns server configuration. You are not required to use your ISP's domain servers (especially if they are slow and sucky;)).

To modify your nameserver 'vi /etc/resolv.conf'(or nano or pico or whatever your favorite editor is)
#To use this file just add entries in this format:
#  nameserver   address
#You can also add static entries with:
#  domain       address

Um your going to have to do some research to get a list of higher level dns servers to bypass your ISPs. Compare your DNS server in windows to the default one used on linux. I really don't think traceroute or tracepath will help since it doesn't seem to be a routing problem, unless you're supposed to be using a proxy server of some type, but usually that would make things slower if you have a broadband connection.
© 2015 UGN Security Forum