UGN Security

old linux machine

Posted By: MESELF

old linux machine - 04/25/04 04:02 AM

hey guys just wondering if any of you guys would be able to help me with a little problem i am having in linux.
166MHz Pentium
3Com 3c905-TX NIC
Maxtor 2GB HDD
ISA Adaptor Card with an ISA to PCI bridge
something is wrong with network setup i think because when it boots up it initializes the 3c59x module (NIC driver) which is correct then runs dhcpcd to get an ip from my router. when dhcpcd executes i can see the activity light on the nic light up as well as the '100' light being permanently lit up. dhcpcd just times out and after it finishes booting the only thing ifconfig reports is lo. ifconfig eth0 gives legit stats and no errors, but there is no line for 'inet addr:' like there is for lo which just says ''. i am thoroughly confused.
Posted By: Infinite

Re: old linux machine - 04/25/04 07:32 AM

open a terminal and type 'ifconfig eth0'. Does it show anything? Make sure everything is the way it's supposed to look.

And moved to *nix forum
Posted By: Gollum

Re: old linux machine - 04/25/04 01:59 PM

what does the network setup look like? do you have a dhcp server? a router hooked up? is it on a cable connection? are you using just a hub for a small lan? if yes to the last one try this:
ifconfig eth0 [ip address] up
the ip can be any arbitrary ip, as long as you set the subnet mask correctly for the rest of the network (and for the linux box)
that probably woudln't work for some of the other setups though. let us know.//
Posted By: MESELF

Re: old linux machine - 04/26/04 12:35 AM

no. it is on a router running a dhcp server. the router is hooked to a cable modem for internet. there is no hub. the computer i am using to type this is hooked up directly to the router, and the old machine is in the same room so i just switch the ethernet cable to the old machine for testing (i know this does not cause problems with the router cuz it works with my xbox) ifconfig eth0 gives lots of info:

Link encap:Ethernet HWaddr 00:60:08:8E:FD:0F
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:2
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:1100 (1.1 Kb)
Interrupt:11 Base address:0x1000

the only thing is that there is no ip address listed, i assume because dhcpcd fails at bootup where it says "broadcasting DHCP_DISCOVER" (thats where it times out, which is like the first step dhcpcd echoes to me). oh and when it says broadcasting DHCP_DISCOVER the "act" light on the nic does flash. the only thing i can think of is that i bought a bogus nic(?). i could try takin the nic out of the machine i am typing this on and putting it in the old computer if you guys think it would be worthwhile to try. and i am too lazy to try static ip unless you guys absolutely insist that i try it, cuz dhcp is so much simpler cuz i dont have to think about all the ip crap.
Posted By: Gollum

Re: old linux machine - 04/26/04 02:02 AM

anything you think could work would always be worthwhile to try. if it is the nic, you could always just go out and buy a new one for like $20. i'm out of ideas though. dhcp does make thigns easier. but, if worst comes to worst, it wouldn't be so hard to stick in a few ifconfig lines into your startup scripts to set up your ip and stuff.//
Posted By: MESELF

Re: old linux machine - 04/26/04 02:31 AM

this is not good lol. im not even sure the computer is worth $20.
Posted By: Infinite

Re: old linux machine - 04/26/04 09:51 AM

Oddly enough I have something of the same problem going on at home right now too. My router's DHCP server and my laptop's client don't see to want to talk anymore. I just set a static IP in the right subnet and forgot about the issue. What kind of router do you have out of curiosity?
Posted By: sinetific

Re: old linux machine - 04/26/04 10:17 AM

When I was using an ISA nic I had to use a few different modules before i could get the card to work. One for the pcibridge, one for isa pnp, and one for the card. You might have to recompile your kernel for this support. A lot of isa cards have really crappy support in linux becuase frankly they arent that widely used. What is the exact manufactuer and model of your network card?
Try to investigate the problem using dmesg. Commands like dmesg | grep isa or dmesg | grep eth should show you if your card is detected and if it's finding a corresponding module.
Posted By: MESELF

Re: old linux machine - 04/27/04 08:22 AM

funny thing is its not an isa card. its a pci card but i think ibm's damn proprietary parts route the pci through the isa bus with some kind of adapter (daughterboard?). the router is a...hmm. i think gigafast? its in the closet. yes thats right its a gigafast. the dhcp on the machine has never worked. ive been fighting with it for god knows how long. see i don't really understand how to set up static ip. maybe if one of you guys could point me somewhere to learn how i could try it. also would the "-TX" on the end of the card signify anything that would cause a problem like this? just wondering. well maybe i will try static ip. just point me where to go and set me off. oh and
manufacturer: 3Com
and on the card itself by where it says 3com it says
3c905-TX (which is what i payed for, so at least i didn't get screwed there)
Posted By: MESELF

Re: old linux machine - 04/27/04 08:36 AM

heh. i feel like an idiot. i got static ip working for the machine im on now. last time i forgot to specify a dns server. so im just using the one my router reports as its "wan dns server" or something like that. so now how do i do it in linux?
Posted By: sinetific

Re: old linux machine - 04/27/04 06:25 PM

echo "nameserver" > /etc/resolve.conf
Posted By: MESELF

Re: old linux machine - 04/27/04 08:15 PM

hmm that works? that seems too simple. don't i have to set the gateway,subnet,and ip? and what is nameserver? (sorry for my ignorance)
Posted By: weeve

Re: old linux machine - 04/27/04 11:50 PM

dood for real netconfig

do a netconfig

setup your router's ip address should be or

an open ip to use, and your dns, on static. don't choose dhcp under netconfig.

Then, if that doesn't work, choose dhcp, and enter the settings you need to. I believe just gateway, and ip. If that. yes echoing the nameserver into /etc/resolv.conf will work. resolv.conf

but so will emacs /etc/resolv.conf and entering it manually. or whatever you wanna use as a editor. I'd suggest startx, and get under xfree. Go gui till you get your box online. Also after your on, log fully out, and log into a new user that's not root. Like adduser whateverusername
Bla bla bla

Deluser or userdel deletes I forget which they changed it a bit back. Um, do this as to not be under super user access online, it's safer, don't ask. Also su to root via. su root then enter the password for root. Do not list info such as passwords online at all. Obvious stuff, But I'm being bluntly obvious.

If this does not work, post again. But all of this should, as this whole thread has gone on to long, I decided to post, and um...I'm guessing by the whole ordeal of the post that you don't know what I'm saying is a good thing to do. All of it. So...try it out, whatever, have fun.
Posted By: MESELF

Re: old linux machine - 04/28/04 01:28 AM

tried setting up(netconfig):
gateway = ip)
nameserver = (cox dns)
ip = (what this computer uses)
subnet mask =
hostname = "ibm"
domain = "mynet"
(the last two it forced me to enter something so i just put in something).
still no go! if i type "ping" it starts pinging but gets 100% packet loss like my router is saying [censored] you or something. and if i try to ping the nameserver it gives "ret=-1" "Network is unreachable".
Edit: And the router is a Gigafast EE400R
Posted By: Gremelin

Re: old linux machine - 04/28/04 05:55 AM

for your name server, enter in your router ip; i have to have that with mysetup.
Posted By: MESELF

Re: old linux machine - 04/28/04 08:09 AM

alright on this computer switching the nameserver to worked but why would that make a difference as to whether or not i could ping the router? i mean i'll try changing that on the old machine but i don't see how it would change the fact that the router is ignoring me (at least i assume thats what is happening.) also, i've heard of this card having some issues with full duplex/half duplex...could that cause a severe problem like this?
Posted By: Gremelin

Re: old linux machine - 04/28/04 08:19 AM

Because you are telling it to use comcast for an ns server when, according to your pc with no connection, there is no comcast (or whatever isp).

Your pc doesn't speak to the internet, it speaks to your router, so you use internal information. If you use external information it'll sit and ponder what the [censored] you're trying to do...
Posted By: sinetific

Re: old linux machine - 04/29/04 04:18 AM

I dont use my router as a nameserver....
I use comcast's name servers shown set up like I told you earlier. You can use external name servers with no problem as long as you set your router's IP as your gateway you'll be all set. You still havent said what card you are using.

#1 do this->
#2 if it works ->
ping (your router ip)
#3 works ->
ping (your nameserver ip)
#4 works ->
#5 if that works everything is fine.

if it fails at #1 your machine is just [censored]. reinstall.
if #2 fails check these commands to make sure everything is set up correctly
if it fails at #3 your routers settings are messed up most likely
if it fails at #4 check this command
cat /etc/resolve.conf
then if you get to #5 all is good.
Posted By: MESELF

Re: old linux machine - 04/29/04 05:03 AM

ping works fine, avg time like 0.4ms. ping (router ip) yields no error messages but the ping program doesnt echo anything and then when i ctrl-c it it says something like 24 packets transmitted, 0 packets recieved, 100% packet loss. (i just control-c after a few seconds).
so... (the categories for the table are Destination, Gateway, Genmask, Flags, Metric, Ref, Use, Iface)
localnet * U 0 0 0 eth0
loopback * U 0 0 0 lo
default UG 1 0 0 eth0

ifconfig(the eth0 part):
Link encap:Ethernet HWaddr 00:60:08:8E:FD:0F
inet addr: Bcast: Mask:
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:54 errors:0 dropped:0 overruns:0 carrier:36
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:3240 (3.1 Kb)
Interrupt:11 Base address:0x1000

the card is a 3Com 3c905-TX with scyld's 3c59x module for the driver
the router is a gigafast EE400R
oh and for some of the pings i accidentally didn't have the ethernet plugged in, just in case that might give some wierd results in ifconfig or something. but for most of them i did.
Posted By: sinetific

Re: old linux machine - 04/30/04 11:42 AM

Well everything looks set up correctly. Since it does recognize the card and it shows up in ifconfig, I doubt it's the module. The settings all look fine, unless there is something im not aware or about your setup(like different routes, additional ethernet cards in your machine, or anything else).
The problem could be physical. Check the cable your using on another machine make sure it's working properly, check the card in another machine if possible to see if it works in there. I don't understand why you would ever need to unplug the ethernet (cable, card, anything...) to ping.

Are you using DHCP or static IP addressing? Try using DHCP and just type in 'dhcpcd' at the root prompt and it will set all that up for you automatically.
Posted By: weeve

Re: old linux machine - 04/30/04 01:43 PM

I hope to hell he/she is using a dhcp, not a static setup on a router lol. Or this whole coversation just got like wasted, and it will get longer:D Dood meself, come on the irc some time. We all like tech talk once in a while. I'm sure one or more of us would love to help you with network problems. As long as your patient, polite, and nice. Pretty much that works for anything, keeps a geek in a good mood, and for real you'll get that fixed right quick I'd imagine.

I myself may or may not be available. As sin giz, or SR may or may not be. Our "schedules", are...rather hectic. Looking forward to seeing this issue resolved.
Posted By: sinetific

Re: old linux machine - 04/30/04 08:42 PM

My router uses dhcp to connect to my ISP. Internally I use a mix of dhcp and static addressing. My servers use static addresses because port forwarding is easier to set up for static addressing. My laptop and other 'browser' computers use dhcp to connect.
Posted By: Gremelin

Re: old linux machine - 05/01/04 04:07 AM

I prefer static addressing definately; especially with port forwarding from a router smirk
Posted By: MESELF

Re: old linux machine - 05/01/04 06:34 AM

heh. thats practically where this all started. i came because dhcp would not work, it just kept timing out. then somone said try static ip so i did. and now i've figured out that for some reason either my router isn't responding to the nic or something is wrong with the nic and its not recieving signals. im gonna try putting the nic in another computer to see if that is whats faulty. oh and the reason for unplugging stuff is this. both computers are in the same room and there is one jack in the wall, so i just take the cable out of this computer and plug it into the old one to test. and there are no other nics or special setups that i know of in the machine.
© 2018 UGN Security Forum