UGN Security

lilo overwrite by kernel

Posted By: Gollum

lilo overwrite by kernel - 02/26/04 10:00 AM i had a problem with my power cord while i was using linux a little while ago. and well, needless to say, i had a problem booting. it said that the second half of my LILO was overwritten by the kernel. now, the way i have it set up is i boot into LILO, then from there i boot to Windows2k or slackware. windows starts up fine, but slackware won't. giving the error above. the problem i've come into, is that b/c i use ntfs, it seems to create other problems when i try to set up to boot into slack without using lilo. has anyone ever had this problem b4?//
Posted By: sinetific

Re: lilo overwrite by kernel - 02/26/04 10:31 AM

Hrm, not exactly that error. Did you install lilo to the MBR or just to a bootable partition? I don't think it can be overwritten in the MBR but I'm not really sure.

Solutions that I would try are:
boot from the slack disk and at the boot: prompt type in:

bare.i root=/dev/hda1 noinitrd ro
*change hda1 with your / partition.

see if that works and if it does you can reinstall lilo from the setup menu.

Use a gentoo boot cd or a live! distro to go in and mount the partitions and repair whatever files need to be replaced manually.
Posted By: Gollum

Re: lilo overwrite by kernel - 02/26/04 11:08 AM

no, i actually tried that right after i made the post. what happened is that it booted, then gave me crap about the reiser fs...even though i had installed ext2 (i wish i had installed either ext3 or something though...oh well, live and learn) i'm downloading knoppix right now to try out...see if that helps. and i tried my slackware rescue cd, but that didn't help...wouldn't let me log in at all.//
Posted By: sinetific

Re: lilo overwrite by kernel - 02/27/04 10:41 AM

didn't you say you used emerde? If you did emerde world it could have [censored] up some of your system files.
Posted By: Gollum

Re: lilo overwrite by kernel - 02/27/04 09:33 PM

nah,i don't use emerde...but dont' worry about it...i just ended up formatting and reinstalling linux. i decided to go with the reiser file system too. ah, at least now i have something to keep me occupied.//
© 2018 UGN Security Forum